Ask Your Question
0

cannot access the localhost:8069

asked 2013-03-20 11:43:21 +0200

Mohsin khan gravatar image Mohsin khan
11 1 2 3

updated 2013-03-20 16:55:58 +0200

Daniel Reis gravatar image Daniel Reis flag of Portugal
2817 5 22 31
http://openerpmanagements...

==== When i open localhsot:8069 then this error is appear i am new in erp help me====

OpenERP Server Error

Client Traceback (most recent call last):
  File "C:\Program Files (x86)\OpenERP 7.0-20130319-002358\Server\server\openerp\addons\web\http.py", line 203, in dispatch
  File "C:\Program Files (x86)\OpenERP 7.0-20130319-002358\Server\server\openerp\addons\web\controllers\main.py", line 747, in get_list
  File "C:\Program Files (x86)\OpenERP 7.0-20130319-002358\Server\server\openerp\addons\web\controllers\main.py", line 89, in db_list
  File "C:\Program Files (x86)\OpenERP 7.0-20130319-002358\Server\server\openerp\addons\web\session.py", line 31, in proxy_method
  File "C:\Program Files (x86)\OpenERP 7.0-20130319-002358\Server\server\openerp\addons\web\session.py", line 104, in send


Server Traceback (most recent call last):
  File "C:\Program Files (x86)\OpenERP 7.0-20130319-002358\Server\server\openerp\addons\web\session.py", line 90, in send
  File "C:\Program Files (x86)\OpenERP 7.0-20130319-002358\Server\server\.\openerp\netsvc.py", line 293, in dispatch_rpc
  File "C:\Program Files (x86)\OpenERP 7.0-20130319-002358\Server\server\.\openerp\service\web_services.py", line 122, in dispatch
  File "C:\Program Files (x86)\OpenERP 7.0-20130319-002358\Server\server\.\openerp\service\web_services.py", line 359, in exp_list
  File "C:\Program Files (x86)\OpenERP 7.0-20130319-002358\Server\server\.\openerp\sql_db.py", line 484, in cursor
  File "C:\Program Files (x86)\OpenERP 7.0-20130319-002358\Server\server\.\openerp\sql_db.py", line 182, in __init__
  File "C:\Program Files (x86)\OpenERP 7.0-20130319-002358\Server\server\.\openerp\sql_db.py", line 377, in _locked
  File "C:\Program Files (x86)\OpenERP 7.0-20130319-002358\Server\server\.\openerp\sql_db.py", line 440, in borrow
  File "psycopg2\__init__.pyc", line 178, in connect
OperationalError: could not connect to server: Connection refused (0x0000274D/10061)
    Is the server running on host "localhost" (::1) and accepting
    TCP/IP connections on port 5432?
received invalid response to SSL negotiation: -
delete close flag offensive retag edit

Comments

How did you make the installation? Did you first tested it without SSL?

ton123 ( 2013-03-20 12:35:58 +0200 )edit

This is a little few information to go on. I assume you installed OpenERP 7 under Windows with the all-in-one client? Can you log in to the postgresql database using the pgadmin III client?

Try if you can access your server directory through pgadmin, you can also backup any of your existing databases here. Were you able to ever connect to OpenERP on localhost, and did it change recently - or were you never able to set it up properly?

Laurens ( 2013-03-20 12:41:14 +0200 )edit

Worst case scenario you can also uninstall OpenERP server and the postgresql server. (+ any additional dependencies if you installed them with stacklauncher after the initial configuaration) Then open a regedit and search for all registry keys from OpenERP and postgresql, delete all of them. Reboot your system and reinstall using the all-in-one launcher, leave all of the settings/options on their default values. (e.g. "localhost" and the port 8069) You should get an out-of-the-box working OpenERP installation for localhost if you just install the necessities and don't change the default values

Laurens ( 2013-03-20 12:43:38 +0200 )edit

3 Answers

Sort by » oldest newest most voted
0

answered 2013-03-20 16:58:58 +0200

Daniel Reis gravatar image Daniel Reis flag of Portugal
2817 5 22 31
http://openerpmanagements...

From your traceback, the problem is that OpenERP is not able to connect to Postgres database:

could not connect to server: Connection refused (0x0000274D/10061)
Is the server running on host "localhost" (::1) and accepting
TCP/IP connections on port 5432?

Check if Postgres is running. If you think so and still have the problem, try connecting using a GUI tool such as pgAdmin.

link publish delete flag offensive edit
0

answered 2013-03-20 23:37:47 +0200

Mind And Go gravatar image Mind And Go flag of France
79 1 1 7
http://mind-and-go.com/so...

Actually,

If postgresql is running, the problem could come from a problem with IPV6 and IPV4 protocols. The (::1) should be bind to the localhost in your lmhost. Maybe you could try to bind it to your IP. I already had this issue with other systems conecting to postgresql

link publish delete flag offensive edit
0

answered 2013-03-21 10:01:05 +0200

omar bajunaid gravatar image omar bajunaid
180 1 3 9

if you are working under Windows go to services and restart the Openerp server or the Postgres server. These servers are set up to start automatically but sometimes they fail. The options you may have are either to Restart or Stop/Start.

link publish delete flag offensive edit

Login/Signup to Answer

Documentation

You can download ebooks on Facebook or buy paper book

You can read the online documentation

Question tools

Follow

subscribe to rss feed

Stats

Asked: 2013-03-20 11:43:21 +0200

Seen: 2,140 times

Last updated: Mar 21 '13